Yesterday, I tried installing Steam beta on Linux.

The package manager gleefully tells me that I need libc6 version 2.15 or newer, and I have woefully old version, 2.13.

(A digression for non-Linux-geeks: libc is a very central component of the Linux system that almost every program uses - it makes them walk, it makes them talk, and makes these programs able to use modern-time conveniences like, oh, files and stuff.)

The thing is, 2.13 is the newest version on 32-bit x86 Debian Unstable. Sure, Debian’s “experimental” branch has newer versions, but unfortunately, I usually interpret Debian’s “unstable” as “shit that usually seems to work” and “experimental” as “might install but there’s absolutely no guarantees it actually works, unless we’re talking about Firefox/Iceweasel, because people actually give damn about it”.

Well, I guess they’re targeting Ubuntu instead of Debian as such, but I still think that someone’s got funny requirements there.

I’m just not brave enough to potentially break my system. So I guess I’ll just go back to waiting.

Oh well, it’s not like the Steam Linux catalogue is that huge as of yet. I have Quake, Doom and most of the other fine id Software games in Steam, but I can’t quite Steam them yet. Sticking to retail copies for now.

(Side note: The most awesome Doom 3 mod ever, The Dark Mod, has apparently been brought to version 1.08 - and they’ve fixed compatibility with older processors so the Linux version runs without SSE2 support in processors. Fannnnnnnntastic.)